GAL Contact Display Does Not Show mobilePhone Field

Assigned to:somebody
Created:somebody at Tue, 09/04/2007 - 5:21pm
Status:Open (General Task / Priority 1-High)
Case ID:Public Display: 209-211

The mobilePhone mapping that I'm creating is NOT showing up on GAL item contact screen.

I followed the instructions to create this Zimbra map entry:

mcf +zimbraGalLdapAttrMap mobile=mobilePhone

And I verified it was there by using this command: /opt/zimbra/bin/zmprov gacf|grep zimbraGalLdapAttr

...
zimbraGalLdapAttrMap: mozillaHomePostalCode=homePostalCode
zimbraGalLdapAttrMap: homePhone=homePhone
zimbraGalLdapAttrMap: mail=email
zimbraGalLdapAttrMap: mobile=carPhone
zimbraGalLdapAttrMap: facsimileTelephoneNumber=workFax
zimbraGalLdapAttrMap: Fax=workFax
zimbraGalLdapAttrMap: mobile=mobilePhone

However, my GAL contact screen shows no mobilePhone field item even though I verified that the LDAP record has a "mobile" attribute with a value.

GAL Test4 User

Submitted issue here: http://www.zimbra.com/forums/installation/11253-gal-mobilephone-attribut...

Revised the question:

http://www.zimbra.com/forums/installation/11253-gal-mobilephone-attribut...

I answered my own question.  "mobilePhone" does, in fact, appear on the GAL Contact Item screen.

The problem is that I had 6 records with the "mobile" attribute.  I originally created this mapping:

mcf +zimbraGalLdapAttrMap mobile=carPhone,mobilePhone

I then modified it as follows:

mcf -zimbraGalLdapAttrMap mobile=carPhone,mobilePhone 
mcf +zimbraGalLdapAttrMap mobile=mobilePhone

Now, new LDAP records I enter display the mobilePhone field on the GAL contact screen, but earlier LDAP records entered do NOT display the mobilePhone field, even though they have "mobile" attribute values.

My question is: Is there some cache that Zimbra maintains with respect to LDAP entries?  I have noticed that when I alter attributes on an existing record (and the attributes are mapped to Zimbra contact fields), they do not show up on Zimbra GAL screen.  However, when I enter new records with all the mapped attributes, these attributes are reflected in the mapped Zimbra contact fields.

Can someone please explain why this is, and what I should do about it?

Thanks!

 

Groups: